I came across a document with lots of tips for efficient Python programming.
Good find, but I think some of these are outdated. For example, you can use list.sort(reverse=True) instead of list.sort(); list.reverse(), sort(key=key) instead of decorate/un-decorate, and as far as readability goes, while True instead of while 1 is slightly more Pythonic (readable) IMO.
Fill in your details below or click an icon to log in:
You are commenting using your WordPress.com account. ( Log Out / Change )
You are commenting using your Twitter account. ( Log Out / Change )
You are commenting using your Facebook account. ( Log Out / Change )
You are commenting using your Google+ account. ( Log Out / Change )
Connecting to %s
Notify me of new comments via email.
Notify me of new posts via email.